#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mU)(?(?<=Analysis of its root cause:\n)((.*\n)*)(?=Details of the fix\n))"
Local $sString = "Analysis of its root cause:" & @CRLF & _
"Blablablablabla" & @CRLF & _
"blabablabkjhjk" & @CRLF & _
"kjbsqbdqbds" & @CRLF & _
"" & @CRLF & _
"Details of the fix" & @CRLF & _
"blablabla" & @CRLF & _
"" & @CRLF & _
"Analysis of its root cause:" & @CRLF & _
"fddsfsdfsdfdsfs" & @CRLF & _
"blnskdbbqbbb" & @CRLF & _
"xxxxggggggg" & @CRLF & _
"" & @CRLF & _
"Details of the fix" & @CRLF & _
"blablabla"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")