const regex = /(?(?<=Analysis of its root cause:\n)((.*\n)*)(?=Details of the fix\n))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?(?<=Analysis of its root cause:\\n)((.*\\n)*)(?=Details of the fix\\n))', 'gm')
const str = `Analysis of its root cause:
Blablablablabla
blabablabkjhjk
kjbsqbdqbds
Details of the fix
blablabla
Analysis of its root cause:
fddsfsdfsdfdsfs
blnskdbbqbbb
xxxxggggggg
Details of the fix
blablabla`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}