re = /(?(?<=Analysis of its root cause:\n)((.*\n)*)(?=Details of the fix\n))/m
str = 'Analysis of its root cause:
Blablablablabla
blabablabkjhjk
kjbsqbdqbds
Details of the fix
blablabla
Analysis of its root cause:
fddsfsdfsdfdsfs
blnskdbbqbbb
xxxxggggggg
Details of the fix
blablabla'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end