using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"0\s*800\d{3}\s*\d{4}|(?:300[34]|400[34]|4020)[\s\.-]?\d{4}|\(?(?:[14689]\d|2[^356\D]|3[^69\D]|5[^267-9\D]|7[^268\D])\)?\s*\d{4}[\s\.-]?\d{4}";
string input = @"<a href=""tel:1123456789"" class=""btn-tel"">(11) 2345-6789</a>
<strong>3003-1234</strong>
<b>3698765432</b><i>3798765432</i>
(22)66669696
<a _ngcontent-iqq-c82="" href=""tel:30031234"" class=""ng-tns-c82-0"">3003-1025 </a>
<sometag>08001234567</sometag>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}