import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "0\\s*800\\d{3}\\s*\\d{4}|(?:300[34]|400[34]|4020)[\\s\\.-]?\\d{4}|\\(?(?:[14689]\\d|2[^356\\D]|3[^69\\D]|5[^267-9\\D]|7[^268\\D])\\)?\\s*\\d{4}[\\s\\.-]?\\d{4}";
final String string = "<a href=\"tel:1123456789\" class=\"btn-tel\">(11) 2345-6789</a>\n"
+ "<strong>3003-1234</strong>\n"
+ "<b>3698765432</b><i>3798765432</i>\n"
+ "(22)66669696\n"
+ "<a _ngcontent-iqq-c82=\"\" href=\"tel:30031234\" class=\"ng-tns-c82-0\">3003-1025 </a>\n"
+ "<sometag>08001234567</sometag>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}