# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"0\s*800\d{3}\s*\d{4}|(?:300[34]|400[34]|4020)[\s\.-]?\d{4}|\(?(?:[14689]\d|2[^356\D]|3[^69\D]|5[^267-9\D]|7[^268\D])\)?\s*\d{4}[\s\.-]?\d{4}"
test_str = ("<a href=\"tel:1123456789\" class=\"btn-tel\">(11) 2345-6789</a>\n"
"<strong>3003-1234</strong>\n"
"<b>3698765432</b><i>3798765432</i>\n"
"(22)66669696\n"
"<a _ngcontent-iqq-c82=\"\" href=\"tel:30031234\" class=\"ng-tns-c82-0\">3003-1025 </a>\n"
"<sometag>08001234567</sometag>")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.