using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=.*[a-z])(?=.*[A-Z])(?=.*\d)(?=.*[@*$#]).{8,16}";
string substitution = @"";
string input = @"1wb1nBass99
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}