import re
regex = re.compile(r"(?=.*[a-z])(?=.*[A-Z])(?=.*\d)(?=.*[@*$#]).{8,16}")
test_str = ("1wb1nBass99\n")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)