re = /(?=.*[a-z])(?=.*[A-Z])(?=.*\d)(?=.*[@*$#]).{8,16}/
str = '1wb1nBass99
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result