const regex = /^\d+(?:,\d+)*\r?\n[^\d\r\n]*(?:Jan|Feb|Mar|Apr|May|Jun|Jul|Aug|Sep|Oct|Nov|Dec)\d{4}[^\d\r\n]*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d+(?:,\\d+)*\\r?\\n[^\\d\\r\\n]*(?:Jan|Feb|Mar|Apr|May|Jun|Jul|Aug|Sep|Oct|Nov|Dec)\\d{4}[^\\d\\r\\n]*$', 'gm')
const str = `hrthrhthrht
bntyjhytjtyj
8,083,344
Mar1996
tggrgge`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}