re = /^\d+(?:,\d+)*\r?\n[^\d\r\n]*(?:Jan|Feb|Mar|Apr|May|Jun|Jul|Aug|Sep|Oct|Nov|Dec)\d{4}[^\d\r\n]*$/m
str = 'hrthrhthrht
bntyjhytjtyj
8,083,344
Mar1996
tggrgge'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end