$re = '/^\d+(?:,\d+)*\r?\n[^\d\r\n]*(?:Jan|Feb|Mar|Apr|May|Jun|Jul|Aug|Sep|Oct|Nov|Dec)\d{4}[^\d\r\n]*$/m';
$str = 'hrthrhthrht
bntyjhytjtyj
8,083,344
Mar1996
tggrgge';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);