#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\/ffff\/eee\.php\?p=([0-9]*)"
Local $sString = "/ffff/eee.php?p=5" & @CRLF & _
"/ffff/eee.php?p=55" & @CRLF & _
"/ffff/eee.php?p=577" & @CRLF & _
"/ffff/eee.php?p=555"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")