$re = '/\/ffff\/eee\.php\?p=([0-9]*)/';
$str = '/ffff/eee.php?p=5
/ffff/eee.php?p=55
/ffff/eee.php?p=577
/ffff/eee.php?p=555';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);