package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\/ffff\/eee\.php\?p=([0-9]*)`)
var str = `/ffff/eee.php?p=5
/ffff/eee.php?p=55
/ffff/eee.php?p=577
/ffff/eee.php?p=555`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}