package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:[^@]+@[^,]+\,){3}`)
var str = `u32iygsfotd4x4@zq0q2qmhkr.com, oni26h0b9g@rciq1js1qq.com, x8_2q5yzig4hn@w8zktw.com,`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}