import re
regex = re.compile(r"(?:[^@]+@[^,]+\,){3}", flags=re.MULTILINE)
test_str = "u32iygsfotd4x4@zq0q2qmhkr.com, oni26h0b9g@rciq1js1qq.com, x8_2q5yzig4hn@w8zktw.com,"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")