using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[\w\-.]+@(stud.)?noroff.no$";
string input = @"baduser@not-noroff.no
gooduser@noroff.no
goodstudent@stud.noroff.no";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}