$re = '/^[\w\-.]+@(stud.)?noroff.no$/m';
$str = 'baduser@not-noroff.no
gooduser@noroff.no
goodstudent@stud.noroff.no';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);