import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?!red:|blue:|green:)[a-z]+(?=:)";
final String string = "(green:bar AND black:foo)\n"
+ "(blue:bar AND darkblue:foo)\n"
+ "(yellow:bar AND grey:foo)\n"
+ "(greengarden:bar AND red:foo)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}