const regex = /number(?P<value>.*?)into|field(?P<field>.*?)of|type(?P<type>.*?)$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('number(?P<value>.*?)into|field(?P<field>.*?)of|type(?P<type>.*?)$', 'g')
const str = `cannot unmarshal number 400.50 into Go struct MyStruct.Numbers of type int64
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}