$re = '/number(?P<value>.*?)into|field(?P<field>.*?)of|type(?P<type>.*?)$/';
$str = 'cannot unmarshal number 400.50 into Go struct MyStruct.Numbers of type int64
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);