// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"number(?P<value>.*?)into|field(?P<field>.*?)of|type(?P<type>.*?)$").unwrap();
let string = "cannot unmarshal number 400.50 into Go struct MyStruct.Numbers of type int64
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}