import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "c\\.a\\.createElement\\(\"tr\"(.*?)c\\.a\\.createElement\\(\"tr\"";
final String string = "{class:\"table table-striped\"},c.a.createElement(\"thead\",{class:\"thread-dark\"},c.a.createElement(\"tr\",null,c.a.createElement(\"th\",{scope:\"col\"},\"Round 1\"),c.a.createElement(\"th\",{scope:\"col\"}),c.a.createElement(\"th\",{scope:\"col\"}),c.a.createElement(\"th\",{scope:\"col\"}),c.a.createElement(\"th\",{scope:\"col\"}))),c.a.createElement(\"tbody\",null,c.a.createElement(\"tr\",null,c.a.createElement(\"td\",null,\"Parc des Princes\",c.a.createElement(\"br\",null),\"Paris\"),c.a.createElement(\"td\",{align:\"right\"},\"France \",c.a.createElement(\"img\",{src:\"img/RoundFlags/France.png\",width:\"50\",hspace:\"20\"})),c.a.createElement(\"td\",{className:\"align-middle\",align:\"center\"},c.a.createElement(\"a\",{href:\"/fra-kor\"},\"4 - 0\")),c.a.createElement(\"td\",{align:\"left\"},c.a.createElement(\"img\",{src:\"img/RoundFlags/Korea.png\",width:\"50\",hspace:\"20\"}),\" Korea\"),c.a.createElement(\"td\",null,\"Group A\")),c.a.createElement(\"tr\",null,c.a.createElement(\"td\",null,\"Roazhon Park\",c.a.createElement(\"br\",null),\"Rennes\"),c.a.createElement(\"td\",{align:\"right\"},\"Germany \",c.a.createElement(\"img\",{src:\"img/RoundFlags/Germany.png\",width:\"50\",hspace:\"20\"})),c.a.createElement(\"td\",{className:\"align-middle\",align:\"center\"},c.a.createElement(\"a\",{href:\"/deu-chn\"},\"1 - 0\")),c.a.createElement(\"td\",{align:\"left\"},c.a.createElement(\"img\",{src:\"img/RoundFlags/China.png\",width:\"50\",hspace:\"20\"}),\" China\"),c.a.createElement(\"td\",null,\"Group B\")),c.a.createElement(\"tr\",null,c.a.createElement(\"td\",null,\"Stade Oceane\",c.a.createElement(\"br\",null),\"Le Havre\"),c.a.createElement(\"td\",{align:\"right\"},\"Spain \",c.a.createElement(\"img\",{src:\"img/RoundFlags/Spain.png\",width:\"50\",hspace:\"20\"})),c.a.createElement(\"td\",{className:\"align-middle\",align:\"center\"}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}