# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"c\.a\.createElement\(\"tr\"(.*?)c\.a\.createElement\(\"tr\""
test_str = "{class:\"table table-striped\"},c.a.createElement(\"thead\",{class:\"thread-dark\"},c.a.createElement(\"tr\",null,c.a.createElement(\"th\",{scope:\"col\"},\"Round 1\"),c.a.createElement(\"th\",{scope:\"col\"}),c.a.createElement(\"th\",{scope:\"col\"}),c.a.createElement(\"th\",{scope:\"col\"}),c.a.createElement(\"th\",{scope:\"col\"}))),c.a.createElement(\"tbody\",null,c.a.createElement(\"tr\",null,c.a.createElement(\"td\",null,\"Parc des Princes\",c.a.createElement(\"br\",null),\"Paris\"),c.a.createElement(\"td\",{align:\"right\"},\"France \",c.a.createElement(\"img\",{src:\"img/RoundFlags/France.png\",width:\"50\",hspace:\"20\"})),c.a.createElement(\"td\",{className:\"align-middle\",align:\"center\"},c.a.createElement(\"a\",{href:\"/fra-kor\"},\"4 - 0\")),c.a.createElement(\"td\",{align:\"left\"},c.a.createElement(\"img\",{src:\"img/RoundFlags/Korea.png\",width:\"50\",hspace:\"20\"}),\" Korea\"),c.a.createElement(\"td\",null,\"Group A\")),c.a.createElement(\"tr\",null,c.a.createElement(\"td\",null,\"Roazhon Park\",c.a.createElement(\"br\",null),\"Rennes\"),c.a.createElement(\"td\",{align:\"right\"},\"Germany \",c.a.createElement(\"img\",{src:\"img/RoundFlags/Germany.png\",width:\"50\",hspace:\"20\"})),c.a.createElement(\"td\",{className:\"align-middle\",align:\"center\"},c.a.createElement(\"a\",{href:\"/deu-chn\"},\"1 - 0\")),c.a.createElement(\"td\",{align:\"left\"},c.a.createElement(\"img\",{src:\"img/RoundFlags/China.png\",width:\"50\",hspace:\"20\"}),\" China\"),c.a.createElement(\"td\",null,\"Group B\")),c.a.createElement(\"tr\",null,c.a.createElement(\"td\",null,\"Stade Oceane\",c.a.createElement(\"br\",null),\"Le Havre\"),c.a.createElement(\"td\",{align:\"right\"},\"Spain \",c.a.createElement(\"img\",{src:\"img/RoundFlags/Spain.png\",width:\"50\",hspace:\"20\"})),c.a.createElement(\"td\",{className:\"align-middle\",align:\"center\"}"
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.