// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)c\.a\.createElement\("tr"(.*?)c\.a\.createElement\("tr""#).unwrap();
let string = "{class:\"table table-striped\"},c.a.createElement(\"thead\",{class:\"thread-dark\"},c.a.createElement(\"tr\",null,c.a.createElement(\"th\",{scope:\"col\"},\"Round 1\"),c.a.createElement(\"th\",{scope:\"col\"}),c.a.createElement(\"th\",{scope:\"col\"}),c.a.createElement(\"th\",{scope:\"col\"}),c.a.createElement(\"th\",{scope:\"col\"}))),c.a.createElement(\"tbody\",null,c.a.createElement(\"tr\",null,c.a.createElement(\"td\",null,\"Parc des Princes\",c.a.createElement(\"br\",null),\"Paris\"),c.a.createElement(\"td\",{align:\"right\"},\"France \",c.a.createElement(\"img\",{src:\"img/RoundFlags/France.png\",width:\"50\",hspace:\"20\"})),c.a.createElement(\"td\",{className:\"align-middle\",align:\"center\"},c.a.createElement(\"a\",{href:\"/fra-kor\"},\"4 - 0\")),c.a.createElement(\"td\",{align:\"left\"},c.a.createElement(\"img\",{src:\"img/RoundFlags/Korea.png\",width:\"50\",hspace:\"20\"}),\" Korea\"),c.a.createElement(\"td\",null,\"Group A\")),c.a.createElement(\"tr\",null,c.a.createElement(\"td\",null,\"Roazhon Park\",c.a.createElement(\"br\",null),\"Rennes\"),c.a.createElement(\"td\",{align:\"right\"},\"Germany \",c.a.createElement(\"img\",{src:\"img/RoundFlags/Germany.png\",width:\"50\",hspace:\"20\"})),c.a.createElement(\"td\",{className:\"align-middle\",align:\"center\"},c.a.createElement(\"a\",{href:\"/deu-chn\"},\"1 - 0\")),c.a.createElement(\"td\",{align:\"left\"},c.a.createElement(\"img\",{src:\"img/RoundFlags/China.png\",width:\"50\",hspace:\"20\"}),\" China\"),c.a.createElement(\"td\",null,\"Group B\")),c.a.createElement(\"tr\",null,c.a.createElement(\"td\",null,\"Stade Oceane\",c.a.createElement(\"br\",null),\"Le Havre\"),c.a.createElement(\"td\",{align:\"right\"},\"Spain \",c.a.createElement(\"img\",{src:\"img/RoundFlags/Spain.png\",width:\"50\",hspace:\"20\"})),c.a.createElement(\"td\",{className:\"align-middle\",align:\"center\"}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}