$re = '/(%)(?=([0-9a-fA-F][^0-9a-fA-F]|[^0-9a-fA-F]))/';
$str = '%d%2524e%25f%255E00%%%252611%25';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);