re = /(%)(?=([0-9a-fA-F][^0-9a-fA-F]|[^0-9a-fA-F]))/
str = '%d%2524e%25f%255E00%%%252611%25'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end