# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[\r\n]+$//;t' <<< "aaaaaaaaaa
11111111111111111111111
2222222222222222222222222222222222222
333333333333333333333333333333333333333
44
55
67
8
9
90
0
-
=-
=
l
j
g
f
d
s
x
cv
b
n
m
j
h
d
d
g
uj
j
j
h
g
f
gt
t
t
t
tt
"