package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[\r\n]+$`)
var str = []byte(`aaaaaaaaaa
11111111111111111111111
2222222222222222222222222222222222222
333333333333333333333333333333333333333
44
55
67
8
9
90
0
-
=-
=
l
j
g
f
d
s
x
cv
b
n
m
j
h
d
d
g
uj
j
j
h
g
f
gt
t
t
t
tt
`)
var substitution = []byte("")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}