import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[0-9]+@[0-9]+(\\.[0-9]{0,4})?(;[0-9]+@[0-9]+(\\.[0-9]{0,4})?)+$";
final String string = "12345@5.6;12345@45;12345@0.5\n"
+ "12345@5.6,12345@45;12345@0.5";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}