re = /^[0-9]+@[0-9]+(\.[0-9]{0,4})?(;[0-9]+@[0-9]+(\.[0-9]{0,4})?)+$/m
str = '12345@5.6;12345@45;12345@0.5
12345@5.6,12345@45;12345@0.5'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end