$re = '/^[0-9]+@[0-9]+(\.[0-9]{0,4})?(;[0-9]+@[0-9]+(\.[0-9]{0,4})?)+$/m';
$str = '12345@5.6;12345@45;12345@0.5
12345@5.6,12345@45;12345@0.5';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);