const regex = new RegExp('<span class=\\'pages\\'>((?:[^<>]*|(?=<!--).*?-->|<((?!span\\b)[^> ]+)[^>]*>.*?</\\2>)*)</span>', 'gm')
const str = `<span class='pages'>1 de <!-- <span> comentado </span> --> <a href="www.google.com">link</a> 8</span><span class='current'>1</span>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}