$re = '%<span class=\'pages\'>((?:[^<>]*|(?=<!--).*?-->|<((?!span\b)[^> ]+)[^>]*>.*?</\2>)*)</span>%m';
$str = '<span class=\'pages\'>1 de <!-- <span> comentado </span> --> <a href="www.google.com">link</a> 8</span><span class=\'current\'>1</span>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);