re = /<span class='pages'>((?:[^<>]*|(?=<!--).*?-->|<((?!span\b)[^> ]+)[^>]*>.*?<\/\2>)*)<\/span>/m
str = '<span class=\'pages\'>1 de <!-- <span> comentado </span> --> <a href="www.google.com">link</a> 8</span><span class=\'current\'>1</span>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end