package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([\w ]+) section (\d) section (\w+) section ((?:\w+\s?)+)`)
var str = `Example task section 1 section tomorrow section tagone tagtwo tagthree tagfour `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}