$re = '/([\w ]+) section (\d) section (\w+) section ((?:\w+\s?)+)/';
$str = 'Example task section 1 section tomorrow section tagone tagtwo tagthree tagfour ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);