re = /([\w ]+) section (\d) section (\w+) section ((?:\w+\s?)+)/
str = 'Example task section 1 section tomorrow section tagone tagtwo tagthree tagfour '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end