const regex = /^(?:[NnoneOoff0-9\\-\\+\\/]+ *(?:, *(?!$)|$))+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[NnoneOoff0-9\\\\-\\\\+\\\\\/]+ *(?:, *(?!$)|$))+$', 'gm')
const str = `207e/160
207e/160, 149/80
207e/160, 149/80, 11
207e/160 , 149/80,11,12,13
207e/160 , 149/80,11,12,13 ,
,207e/160 , 149/80,11,12,13
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}