import Foundation
let pattern = #"^(?:[NnoneOoff0-9\\-\\+\\/]+ *(?:, *(?!$)|$))+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
207e/160
207e/160, 149/80
207e/160, 149/80, 11
207e/160 , 149/80,11,12,13
207e/160 , 149/80,11,12,13 ,
,207e/160 , 149/80,11,12,13
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)