re = /^(?:[NnoneOoff0-9\\-\\+\\\/]+ *(?:, *(?!$)|$))+$/m
str = '207e/160
207e/160, 149/80
207e/160, 149/80, 11
207e/160 , 149/80,11,12,13
207e/160 , 149/80,11,12,13 ,
,207e/160 , 149/80,11,12,13
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end