import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.*[a-z])(?=.*[A-Z])(?=.*\\d)(?=.*[ !\"#$%£&'()*+,-.\\/:;<=>?@[\\\\\\]^_`\\{|\\}~])[A-Za-z\\d !\"#$£%&'()*+,-.\\/:;<=>?@[\\\\\\]^_`\\{|\\}~]{8,32}$";
final String string = "Test-123\\!!!!!/!!\n"
+ "Test 123[!!!!!!!\n"
+ "Test_123£}!!\\!!!!!\n"
+ "Test_123!!_!!!!!";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}