re = /^(?=.*[a-z])(?=.*[A-Z])(?=.*\d)(?=.*[ !"#$%£&'()*+,-.\/:;<=>?@[\\\]^_`{|}~])[A-Za-z\d !"#$£%&'()*+,-.\/:;<=>?@[\\\]^_`{|}~]{8,32}$/m
str = 'Test-123\\!!!!!/!!
Test 123[!!!!!!!
Test_123£}!!\\!!!!!
Test_123!!_!!!!!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end