$re = '/^(?=.*[a-z])(?=.*[A-Z])(?=.*\d)(?=.*[ !"#$%£&\'()*+,-.\/:;<=>?@[\\\\\]^_`{|}~])[A-Za-z\d !"#$£%&\'()*+,-.\/:;<=>?@[\\\\\]^_`{|}~]{8,32}$/m';
$str = 'Test-123\\!!!!!/!!
Test 123[!!!!!!!
Test_123£}!!\\!!!!!
Test_123!!_!!!!!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);