using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.{65})[\w'-]+(?:\.[\w'-]+)*$";
string input = @".
..
.a.
a.a
abc123_'-.b
1234567890123456789012345678901234567890123456789012345678901234
12345678901234567890123456789012345678901234567890123456789012345";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}