import re
regex = re.compile(r"^(?!.{65})[\w'-]+(?:\.[\w'-]+)*$", flags=re.MULTILINE)
test_str = (".\n"
"..\n"
".a.\n"
"a.a\n"
"abc123_'-.b\n"
"1234567890123456789012345678901234567890123456789012345678901234\n"
"12345678901234567890123456789012345678901234567890123456789012345")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")