re = /^(?!.{65})[\w'-]+(?:\.[\w'-]+)*$/m
str = '.
..
.a.
a.a
abc123_\'-.b
1234567890123456789012345678901234567890123456789012345678901234
12345678901234567890123456789012345678901234567890123456789012345'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end