using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<url>(?:https?:\/\/)?(?:[^@\/\n]+@)?(?:www\.)?(?P<domain>[^:\/?\n]+))/*.*";
string input = @"http://google.com/sldjakdjadlkf
https://www.yahoo.com/dkajldakjfdk?dajfdlkfdj_=$
https://www.bing.com
https://google.com.in/dlajfkdlakdffd
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}