package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?P<url>(?:https?:\/\/)?(?:[^@\/\n]+@)?(?:www\.)?(?P<domain>[^:\/?\n]+))/*.*`)
var str = `http://google.com/sldjakdjadlkf
https://www.yahoo.com/dkajldakjfdk?dajfdlkfdj_=$
https://www.bing.com
https://google.com.in/dlajfkdlakdffd
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}